В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
iamzayka
iamzayka
21.08.2021 12:18 •  Информатика

Здравствуйте! Не могли вы написать программу, которая посчитает количество трехзначных чисел кратных четырём. Чисел изначально n. (через for)​

Ответ:
anast1sava
anast1sava
26.02.2021 09:13

var

 n, count, i: integer;

begin

 count := 0;

 write('Введите трехзначное число n: ');

 readln(n);

 if ((n < 100) or (n > 999)) then

   writeln(' Число не трехзначное!')

 else

 begin

   begin

     for i := 100 to n do

       if i mod 4 = 0 then count := count + 1;

   end;

   writeln(' Количество трехзначных чисел кратных четырем = ', count);

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?