В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
aleks1yus
aleks1yus
18.05.2022 14:19 •  Информатика

Написать программу нахождения минимального из 4 чисел используя процедуру нахождения наименьшего из двух чисел.

Ответ:
герман78
герман78
26.01.2021 23:20

У вас там преподаватели вообще не запариваются с написанием домашки? Второй раз за день одно задание.

var x,y,z,n,min1,min2: integer;

procedure Minim(a,b: integer; var min: integer);

begin

 if a<b then min:=a else min:=b;

end;

begin

 writeln('Введите 4 числа ');

 readln(x,y,z,n);

 Minim(x,y,min1);

 Minim(z,n,min2);

 Minim(min1,min2,x); //x нам уже не нужен. А чем объявлять еще одну переменную, давай использовать ненужную

 writeln('Минимальное число из четырех =',x);

end.

0,0(0 оценок)
Ответ:
ccallul
ccallul
26.01.2021 23:20

var x,y,z,n,min1,min2: integer;

procedure Minim(a,b: integer; var min: integer);

begin

if a<b then min:=a else min:=b;

end;

begin

writeln('Введите 4 числа ');

readln(x,y,z,n);

Minim(x,y,min1);

Minim(z,n,min2);

Minim(min1,min2,x);

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?