В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Дан целочисленный массив состоящий из элементов, элементы массива принимают значение от 0 до 100. составьте программу для вычисления произведения элементов массива, которые не четны и делятся на 3.

Ответ:
Karelovamark
Karelovamark
15.06.2020 09:21

const n=10;
var
a:array [1..n] of integer;
i,s:integer;
begin
Randomize;
for i:=1 to n do
begin
  a[i]:=random(100);
  write(a[i],' ');
end;
for i:=1 to n do if (a[i] mod 2 =1) and (a[i] mod 3 =0) then if s=0 then s:=a[i] else s:=s*a[i];
writeln;
writeln(s);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?