В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Shagovikova08
Shagovikova08
26.04.2021 23:14 •  Информатика

Дан массив из 10 целых чисел. Напишите программу вычисления суммы элементов массива среди, трехзначных чисел, у которых последняя цифра четная, первая нечетная. Нужна программа

Ответ:
sasha1836
sasha1836
25.02.2021 05:40

program z1;

var a:array[1..10] of integer;

i,s:integer;

begin

s:=0;

write('Массив: ');

for i:= 1 to 10 do

begin  

a[i]:=random(1000);  

write(a[i],'  ');

if (a[i]>99) and (a[i]<1000) and (a[i] mod 10 mod 2 = 0) and (a[i] div 100 mod 2 <> 0) then s:=s+a[i]

end;

writeln;

write('Сумма элементов массива среди, трехзначных чисел, у которых последняя цифра четная, первая нечетная: ',s)

end.

Объяснение:

(a[i]>99) and (a[i]<1000) - проверка числа на трёхзначность

(a[i] mod 10 mod 2 = 0) - проверка последней цифры числа на чётность

(a[i] div 100 mod 2 <> 0) - проверка первой цифры числа на нечётность

все условия соединены and, т.к. должны выполняться одновременно

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?