В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составить программу, которая каждое введенное положительное число увеличивает в два раза, а отрицательное возводит в квадрат.

Ответ:
Karbobo
Karbobo
01.10.2020 02:04

Pascal ABC

 

var a : integer;
begin
readln(a);
If a >= 0 then a := 2*a;
If a < 0 then a := a*a;
writeln(a)
end.

0,0(0 оценок)
Ответ:
Таксман
Таксман
01.10.2020 02:04

program z1;

uses crt;

var x,y:integer;

begin

clrscr;

writeln('введи число');

readln(x);

if x>=0 then x:=x*2 

else

if x<0 then sqr(x);

writeln(x);

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?