В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Марося
Марося
11.03.2022 17:19 •  Информатика

Pascal - Задача решить. Составить программу, вычисляющую стоимость покупки с учетом скидки: если покупка превышает 1500 р., то начисляется скидка 3%, если превышает 2000, то начисляется скидка 5%. Выше 4000 - скадка 7%. На вход - стоимость покупки, выход - сколько нужно оплатить.

Ответ:
angelinakovalev
angelinakovalev
15.02.2021 17:36

var x: real;

begin

  writeln('введите цену товара');

 read(x);

 if x>4000 then x:=x-x*0.07 else

    if x>2000 then x:=x-x*0.05 else

      if x>1500 then x:=x-x*0.03;

    write(x)

     

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?