В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Elina558548
Elina558548
20.01.2021 02:09 •  Информатика

Написать программу, которая формирует случайным образом массив из n целых чисел, лежащих в диапазоне от 1 до 5, после чего на экран выводится сам массив и номера элементов, с первым элементом

Ответ:
Vasya1godik
Vasya1godik
14.06.2020 14:59

const

  N = 5;

 

var

  a: array [1..N] of integer;

  i: integer;

 

begin

  for i:= 1 to N do

    a[i]:= random(5) + 1;

  writeln('Сформированный массив:');

  for i:= 1 to N do

    writeln(a[i]);

  writeln('Номера элементов, совпадающих с первым элементом:');

  for i:= 2 to N do

    if a[i] = a[1] then writeln(i);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?