В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nastik1102
nastik1102
29.07.2021 18:16 •  Информатика

Написать программу на паскале, которая формирует случайным образом массив из n- целых чисел, лежащих в диапозоне от 1 до 5, вывести сма массив и номера элементов с первым элементом.

Ответ:
Ksenia17200013er
Ksenia17200013er
14.06.2020 13:19

program zadanie;
var
a: array[1..99999] of real;
i,n: integer;
begin
randomize;
write('Введите число чисел массива: '); readln(n);
for i:=1 to n do
begin
a[i]:=1+random(5);
writeln('a[', i, ']=', a[i]);
end;
write('Номера элементов, совпадающих с первым элементом: ');
for i:=1 to n do if a[i+1]=a[1] then write(i+1:3);
writeln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?