В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Cat4ik
Cat4ik
29.07.2021 18:16 •  Информатика

На циклы. составить программу в ! ! 3. однажды умный бедняк попросил у скупого богача приюта на две недели, причем сказал: «за это я заплачу тебе в первый день 1 рубль, во второй - 2, в третий -3 и т.д., но ты будешь мне подавать милостыню: в первый день 1 копейку, во второй -2, в третий-4 и т.д. увеличивая милостыню каждый день вдвое». богач с радостью согласился. сколько барыша принесла эта сделка богачу?

Ответ:
vika02bel
vika02bel
14.06.2020 13:18

program zadanie;
var
i, n: integer;
bednyak, bogaty: real;
begin
bednyak:=0;
bogaty:=1;
n:=1;
for i:=1 to 14 do
begin
bednyak:=bednyak+1;
bogaty:=bogaty+n;
n:=n*2;
end;
bogaty:=bogaty/100;
writeln('Заплатил бедняк богачу (рублей): ', bednyak);
writeln('Заплатил богач бедняку (рублей): ', bogaty);
writeln('ответ: Богач заплатил бедняку на ', bogaty, ' рублей больше');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?