В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
БЕЙТУЛЛА
БЕЙТУЛЛА
04.06.2020 20:57 •  Информатика

Дано натуральное число. Напишите программу, которая вычисляет сколько раз в нем встречается последняя цифра

Ответ:
viktr1
viktr1
13.01.2021 22:00

program z1;

var a,k,p:integer;

begin

write('Введите число: ');

readln(a);

k:=0;

p:=a mod 10;

while a>0 do

begin

if a mod 10 = p then k:=k+1;

a:=a div 10

end;

writeln(k,' раз(-а) встречается последняя цифра')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?