В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kristina758
kristina758
03.05.2023 21:25 •  Информатика

Написать программу которая 10 раз выводит на екран имя и фамилию. это турбо паскаль - использование цыклов while, for и других. ))

Ответ:
виолетта111111111113
виолетта111111111113
14.06.2020 08:36

Ниже жирным шрифтом приведен код программы на Паскале. В фигурных скобках обычным шрифтом - комментарии. Можно их оставить - компилятор не сможет их прочитать и программа все равно будет работать.

 

 

program printname;
var first_name, family_name : string;
i : byte;

begin
write('Введи свое имя: ');
readln(first_name); {считываем имя в переменную first_name}
write('Введи свою фамилию: ');
readln(family_name); {считываем фамилию в переменную family_name}
for i := 1 to 10 do writeln(family_name, ' ', first_name); {В цикле for со счетчиком i изменяющимся от 1 до 10 печатаем строки с фамилией и именем через пробел}
end.

0,0(0 оценок)
Ответ:
hfhfhfhffhhfdkdd
hfhfhfhffhhfdkdd
14.06.2020 08:36

// Программа выводит по 10 раз имя и фамилию тремя разными циклами for while

// repeat until

 

Program LoopName;

Uses Crt;

var name,s_name:string;

       i:integer;

begin

    clrscr;

    write('Введите имя: ');

    readln(name);

   write('Введите фамилию: ');

   readln(s_name);

   writeln('Цикл For');

 

   for i:=1 to 10 do writeln(name,'  ',s_name );

 

   writeln;

  writeln('Цикл while'); 

    i:=1;

   while (i<=10) do

      begin  

          writeln(name,'  ',s_name );

           i:=i+1;

       end;  

 

   writeln;  

   writeln('Цикл repeat until');

         

    i:=0; 

    repeat

          writeln(name,'  ',s_name );

           i:=i+1;

     until(i=10); 

   readkey; 

 end.

 

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?