В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Акинаки
Акинаки
09.10.2020 01:58 •  Информатика

НА Python У вас есть с собой T (T вводится с клавиатуры) золотых монет.

Местные жители согласились продать вам припасы, но у них есть странный ритуал. Всего в деревне n (n вводится с клавиатуры) жителей, у каждого из них цена за килограмм припасов составляет определенное количество монет (число монет для каждого жителя вводится с клавиатуры и собирается в список).

Вы должны покупать припасы следующим образом:

Сначала покупаете 1 кг у первого жителя, потом идете ко второму, независимо от того, хватило ли денег, потом идете к третьему, и т.д. Как только обойдете всех жителей, идете снова к первому, потом ко второму и т.д.

Напишите программу, которая определит, сколько всего кг припасов вы можете купить по такому принципу.

Оптимизируйте программу, максимально снизив количество итераций в цикле

Ответ:
Orange717
Orange717
12.02.2021 22:42

T = int(input())

lst = [int(input()) for i in range(int(input()))]

t1, kg = 0,0

while True:

   for i in lst:

       if (T-i) >= 0:

           T-=i; kg+=1

       else: t1 = 1

   if t1 == 1: break

print(kg)

Кажись так ~

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?