В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ваня1259
ваня1259
26.01.2021 09:50 •  Информатика

Составить программу для вычисления суммы бесконечного ряда с использованием оператора цикла Язык - Pascal


Составить программу для вычисления суммы бесконечного ряда с использованием оператора цикла Язык - P

Ответ:
lands4552
lands4552
12.02.2021 22:27

var

 k,h:integer;

 p,s,x,eps,n,p1:real;

begin

 x:=10;

 while (x<0) or (1<x) do begin   {Условие ввода 0>x>1}

   write('Введите X = '); readln(x);

   end;

 eps:=1e-@;   //В место @ нужно ввести погрешность в положительном числовом виде (вычислить до @-го знака после запятой)

 p:=x;

 n:=2;

 p1:=1;

 h:=1;

 while abs(p)>eps do   {Условие выхода: очередной член ряда по модулю меньше eps}

 begin

   writeln('[Отладка]  ',eps,'    ',p,'    ',s,'    ',n);   //отладка

   for var i:=0 to 1 do begin

     k:=k+1;

     p1:=p1*k;

   end;

   h:=h*-1;

   p:=h*(power(2*x,n))/p1;   {Вычисление очередного члена ряда}

   s:=s+p;

   n:=n+2;

 end;

 writeln('cos(2x-1) = ', s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?