В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
karinasss1
karinasss1
07.05.2023 09:21 •  Информатика

Напишите программу, которая выводит в одну строчку все делители переданного ей числа, разделяя их пробелами. Входные данные
Входная строка содержит натуральное число.

Выходные данные
Программа должна вывести в строчку все делители переданного ей числа, разделив их пробелами.

Ответ:
masha6610
masha6610
04.01.2021 16:20

n = int(input())

for i in range(1,n+1):

   if n % i == 0:

       print(i,end=" ")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?