В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dasew1
dasew1
11.11.2021 12:48 •  Информатика

Напишите программу , которая выводит номера билетов, чтобы они не повторялись

Ответ:
Klari1Faer
Klari1Faer
14.06.2020 06:49

Я так понимаю намера билетов надо вывести в случайном порядке?

Пусть надо вывести в случайном порядке номера 100 билетов

program RND;

var a:array[1..100]of integer;

i.j,f:integer;

begin

randomize;

i:=1;

white i<101 do begin

f:=0;

A[i]:=int(random(100));

for j:=1 to i do if A[j]=A[i] then f:=1;

if f=0 then i:=i+1;

end;

for i:=1 to 100 do writeln(A[i]);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?