В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
samayazeynalova02
samayazeynalova02
08.09.2020 15:10 •  Информатика

ДАЮ 65Б НУЖНО РЕШЕНИЕ НА ЯЗЫКЕ ПИТОН ЧЕРЕЗ ЦИКЛ for
Задано натуральное число N. Напишите программу, которая выведет на экран все числа: сначала число N, а затем числа от 1 до N - 1.

Входные данные
Вводится одно натуральное число, не превосходящее 1000

Выходные данные
Выведите N - 1 натуральное число. Числа должны быть разделены пробелами.

Примеры
входные данные
5
выходные данные
5 1 2 3 4

Ответ:
irkaShpagina
irkaShpagina
29.01.2021 09:40

#вводим число n

n = int(input())

#создаем массив

values = []

#проверяем что бы число не превышало 1000

if(n <= 1000):

#добавляем в массив число n

   values.append(n)

#делаем цикл и добавляем каждое число от 1 до n-1

   for i in range (1 , n):

       values.append(i)

#делаем цикл и выводим конкатинируя значения в 1 строчку

for i in range(0, len(values)):

   print(values[i], end = ' ')

0,0(0 оценок)
Ответ:
232306
232306
29.01.2021 09:40

n = int(input())

print_data = 0

while not n <= 1000:

   n = int(input())

output = []

output.append(n)

for i in range(1, 1000):

   output.append(i)

   if i >= n or i == 1000:

       output.pop(len(output) - 1)

       break

for i in range(0, len(output)):

   print_data = str(print_data) + str(output[i]) + ' '

print_data = print_data.replace(print_data[0], '', 1)

print(print_data)

print(output)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?