В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
AndreySolmikov
AndreySolmikov
27.11.2020 23:54 •  Информатика

Написать программу на языке Python3.x, формирующую два списка с
координатами X и Y соответственно по запросу с клавиатуры и строящую
двухмерный график на основании этих данных. Объем этих списков также
задавать с клавиатуры.​

Ответ:
Sinderella2006
Sinderella2006
12.02.2021 21:33

import matplotlib.pyplot as plt

x = []

y = []

print("Enter size: ")

size = int(input())

for i in range(0, size):

   print("enter x[" + str(i+1) + "]:")

   x.append(float(input()))

   print("enter y[" + str(i+1) + "]:")

   y.append(float(input()))

plt.plot(x,y)

plt.xlabel('x')

plt.ylabel('y')

plt.title('Graph')

plt.show()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?