В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
murzyeva1970
murzyeva1970
12.04.2020 22:39 •  Информатика

Ниже на языке программирования Pascal записан алгоритм. var x, L, M: integer;
begin
readln(x);
L := 1;
M := 0;
while x > 0 do
begin
M := M + 1;
if x mod 2 <> 0 then
L := L * (x mod 8);
x := x div 8
end;
writeln(L);
writeln(M)
end.
Получив на вход натуральное десятичное число x этот алгоритм печатает два числа: L и M
Укажите наибольшее число x при вводе которого алгоритм печатает сначала 35 а потом 3

Ответ:
lmarki2003
lmarki2003
28.12.2020 11:10

может вот эт или или

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?