В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
tsagol10
tsagol10
13.05.2020 22:57 •  Информатика

15.2 Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 6 и оканчивающихся на 4. Программа получает на вход количество
чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число:
количество чисел, кратных 6 и оканчивающихся на 4.


15.2 Напишите программу, которая в последовательности натуральных чисел определяет количество чисел,

Ответ:
kristinamoroz1
kristinamoroz1
26.01.2021 15:36

c++

Объяснение:

#include <iostream>

using namespace std;

int main() {

int n,num,iter=0;

cin>>n;

for (int i=0;i<n;i++){

 cin>>num;

 if (num%6==0 && num%10==4)

  iter++;

}

cout<<iter; //вывод

return 0;

}

0,0(0 оценок)
Ответ:
666Chocolate666
666Chocolate666
26.01.2021 15:36

var

n,x,i,counter : integer;

begin

counter := 0;

readln(n);

for i := 1 to n do

begin

readln(x);

if (x mod 10 = 4) and (x mod 6 = 0) then

counter := counter + 1;

end;

writeln(counter);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?