В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
romashchenko17
romashchenko17
12.04.2023 22:43 •  Информатика

Напишите программу вычисления выражения: S=x3+x5+xn . Используйте функцию для возведения числа в степень function VozvStep(a,k:integer):integer;
var i:integer;
begin
result:=1; for i:=1 to k do
result:=result*a;
vozvstep:=result;
end;

Ответ:
12575
12575
25.01.2021 17:58

см.объяснение

Объяснение:

program prog;

var  sum,x,n:integer;

function VozvStep(a,k:integer):integer;

var i,res:integer;

begin

res:=1;

for i:=1 to k do res:=res*a;

VozvStep:=res;

end;

begin

Writeln('Enter x,n: ');

readln(x,n);

sum:=VozvStep(x,5)+VozvStep(x,3)+VozvStep(x,n);

writeln('result = ',sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?