В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составить программу , определяющую в каком из данных двух чисел больше четных цифр язык программирования Pascal)

Ответ:
nastikus555
nastikus555
25.01.2021 13:48

см. объяснения + скрин

Объяснение:

program prog;

var

  num,chetnoe,nechetnoe,ost :integer;

begin

writeln('Vvedite chislo:');

readln(num);

chetnoe:=0;

nechetnoe:=0;

if num=0 then chetnoe:=1 else

begin

 while (num<>0) do begin

  ost:=(num mod 10) mod 2;

  if (ost=0) then chetnoe:=chetnoe+1

  else nechetnoe:=nechetnoe+1;

  num:=num div 10;

 end;

end;

writeln('четныx = ',chetnoe);

writeln('нечетных = ',nechetnoe);

end.


Составить программу , определяющую в каком из данных двух чисел больше четных цифр язык программиров
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?