В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
alexnatur
alexnatur
28.02.2023 23:09 •  Информатика

Составьте программу на языке программирования Object Pascal для вычисления значений функции F(x)= x – sin x на отрезке [a,b] с шагом h. Результат представить в виде таблицы, первый столбец которой – значения аргумента, второй – соответствующее значение функции. Заранее

Ответ:
kknopcka
kknopcka
25.01.2021 11:09

var

a,b,h:real;

function f:real;

begin

f:=0;

while a<=b do begin

f:=cos(a)+(sin(a)/cos(a));

writeln(a:2:2,' ',f:2:2);

a:=a+h;

end;

end;

begin

readln(a,b,h);

f;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?