В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Alinazay1
Alinazay1
30.06.2021 18:41 •  Информатика

Написать программу создания одномерного массива, состоящего из 15 элементов , с датчика случайных чисел​

Ответ:
Kristoforeska
Kristoforeska
24.01.2021 19:08

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38

a, b : array [1..n] of integer;

i, max, min, p, imax, imin : integer;

begin

randomize;

writeln('исходный массив a[]:');

for i := 1 to n do

begin

a[i] := random(50) - 25;

write(a[i]:8)

end;

writeln;

{формируем и выводим новый}

{сразу осуществляем поиск максимума и минимума}

max := -1000; min := 1000;

writeln('новый массив b[]:');

for i := 1 to n do

begin

b[i] := a[i] * a[i] * a[i];

write(b[i]:8);

if b[i] > max then

begin

imax := i;

max := b[i]

end;

if b[i] < min then

begin

imin := i;

min := b[i]

end

end;

writeln;

{считаем произведение и выводим результаты}

p := max * min;

writeln('максимальный элемент нового массива - b[', imax, '] = ', max);

writeln('минимальный элемент нового массива - b[', imin, '] = ', min);

writeln('их произведение = ', p);

readln

end.

0,0(0 оценок)
Ответ:
русланчик8
русланчик8
24.01.2021 19:08

ответ я сам не знаю но я думаю что...

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?