В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Malishok12345
Malishok12345
15.06.2020 13:04 •  Информатика

Программирование на Python. Напишите программу-калькулятор: пользователь вводит 5 целых чисел, после чего программа должна вывести их произведение. Чтобы перемножать числа было не слишком легко, нули не учитывайте.
Гарантируется, что не все введённые числа — нули.

Ответ:
Werevolk1
Werevolk1
23.01.2021 15:41

print("Введите 5 чисел, каждое число с новой строки ")

x = [float(input()) for i in range(5)]

pr = 1

for i in range(len(x)):

   if x[i] != 0:

       pr *= x[i]

print(pr)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?