В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kantuz
kantuz
26.01.2020 15:56 •  Информатика

Составьте программу определения количества четных цифр в данном целом числе и вывода второй его цифры.

Ответ:
ar2018borisov
ar2018borisov
21.01.2021 23:04

var

 N: integer;

 s: string;

 i,c: byte;

begin

 ReadLn(N);

 Str(N,s);

 c:=0;

 for i:=1 to Length(s) do

   if s[i] in ['0','2','4','6','8'] then

     Inc(c);

   Writeln(s[2]);

 WriteLn(c);

 ReadLn

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?