В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составьте программу замены в слове,введенном с клавиатуры,всех букв"и" на"а"и"а"на"о".сосчитать количество замен.отладка программы для слова"накидка"

Ответ:
орион12
орион12
13.06.2020 22:09

Program Stroka;

Uses Crt;

var a:string;

 

      c1,c2, i,k:integer; 

begin

    clrscr;

    write('Введите строку: ');

    readln(a);

    k:=length(a);

c1:=0;c2:=0;

 

// Первый проход меняем "и" на  "a"  

   for i:=1 to k do   if(a[i]='и') or (a[i]='И') then

        begin  

               a[i]:='а';

               c1:=c1+1;

 

         end;

    // Второй проход меняем "а" на  "о"    

 

   for i:=1 to k do   if(a[i]='а') or (a[i]='А') then

            begin

 

                 a[i]:='о';     

                  c2:=c2+1;  

 

             end;

writeln;

 

 

 

 writeln('Строка после всех замен:',a);

 

 writeln('Замен и на а:',c1);

  writeln('Замен a на о:',c2); 

    readkey;

 

end. 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?