В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
guluamovalera
guluamovalera
28.04.2022 22:11 •  Информатика

1. написать программу, которая подсчитывает количество четных чисел в массиве целых чисел. количество элементов массива равно n.

Ответ:
10MisisVika10
10MisisVika10
13.06.2020 22:09

Решение на языке C:

 

#include <stdio.h>

int func(int *array, int n)
{
  int result = 0;
  for (int i = 0; i < n; i++) {
    if (array[i] % 2 == 0) {
      result++;
    }
  }
  return result;
}

int main(int argc, char *argv)
{
  int array[] = {1, 2 , 3 , 4 , 5 , 6, 7, 46};
  printf("%d", func(array, 8));
  return 0;
}

0,0(0 оценок)
Ответ:
алинагг
алинагг
13.06.2020 22:09

// Язык Паскаль 

Program Massiv;

Uses Crt;

const n=10; // Нужно больше сам подставишь нужное число

 

 var a:array[1..n] of integer;

        i,c:integer;

begin

     clrscr;

     write('Введите элементы массива: ');

     c:=0;  

     for i:=1 to n do

        begin  

            readln(a[i]); 

 

            if (a[i] mod 2)=0 then c:=c+1; 

 

        end; 

 

writeln;

write('Исходный массив:');

 for i:=1 to n do write(a[i],'  ');

writeln('Количество чётных элементов: ',c); 

   readkey;

 

end. 

 

 

 

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?