В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
xnxnxnxnx
xnxnxnxnx
03.04.2023 07:24 •  Информатика

Pascal, составить программу с задачей! Компьютер запрашивает радиус круга и сторону квадрата. Надо определить, равные ли у них площади (ответ должен иметь вид: «Площади равные»). Если площади не равные, то выводится площадь меньшей фигуры.

Ответ:
дарька4568
дарька4568
15.01.2021 22:25

//s1 - площадь круга, s2 - площадь квадрата

//а - cторона квадрата, r - радиус круга

const pi = 3.14;

var s1,s2,a,r:real;

begin

 write('введите а: ');

 read(a);

 write('введите r: ');

 read(r);

 s1:=pi*sqr(r);

 s2:=sqr(a);

 if s1 = s2 then writeln('площади равные')

 else

   if s1 > s2 then writeln('площадь квадрата: ',s2)

   else

     if s2 > s1 then writeln('площадь круга: ',s1);

end.

0,0(0 оценок)
Ответ:
esken576
esken576
15.01.2021 22:25

var a,r:real;

begin

 readln(r);

 readln(a);

 if (a*a)=(r*r*pi) then

   writeln('Площади равны')

 else

   if (a*a)>(r*r*pi) then

     writeln('Площадь круга меньше, она равна: ', r*r*pi)

   else

     writeln('Площадь квадрата меньше, она равна: ', a*a)

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?