В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Jason19
Jason19
06.04.2020 22:45 •  Информатика

Дано целое двузначное число. составить программу которая определяет входит ли в него цифра 4

Ответ:
chornaya03
chornaya03
13.06.2020 11:13
На псевдокоде
Алг(a,b,fl)
Арг a,b
Рез fl
ввод(a;b) {где а-это десятки,b-еденицы}
fl:=true
Если (a=4)или(b=4) то fl:=true все
Если fl=true то вывод('есть') иначе вывод('нету')
конец
0,0(0 оценок)
Ответ:
kataysinkevich
kataysinkevich
13.06.2020 11:13

var

  a:byte;

begin

  write('Введите число '); readln(a);

  if (a div 10 = 4) or (a mod 10 = 4) then

    writeln('В число входит цифра 4')

  else

    writeln('цифра 4 в число не входит');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?