В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
AndreevaAS2
AndreevaAS2
02.07.2021 16:50 •  Информатика

1. Напишите программу к задаче: Дан массив С (40), заполненный трехзначными случайными числами. Найти произведение четных элементов и сумму нечетных элементов массива.

2. Напишите программу к задаче:
Дан массив А (120), заполненный трехзначными случайными числами. Найти произведение тех элементов, которые принадлежат отрезку (30,60) и сумму тех элементов, которые кратны 6.

Ответ:
Хорошист992017
Хорошист992017
15.12.2020 16:40

C++Выделить код

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

#include <iostream>

#include <cstdlib>

#include <ctime>

 

using namespace std;

 

int main()

{

 int N = 0;

 double mult = 1.0;

 

 srand(time(NULL));

 

 cout << "VVedite N =";

 cin >> N;

 

 int *mas = new int[N];

 

 for(int i = 0; i < N; i++)

  {

   mas[i] = rand() % N;

    cout << "mas[" << i << "]= " <<mas[i] << endl;

    if(mas[i] % 2 != 0)

    {

     mult*=mas[i];

    }

  }

 

delete []mas;

cout << endl;

cout << "MULT = " << mult << endl;

   return 0;

}

Объяснение:

честно я не очень в этом шарю так что проверь )

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?