В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
daniar16
daniar16
29.12.2022 16:25 •  Информатика

Составить программу на С++ Создайте массив из 10 ячеек числа введите на клавиатуре от 1 до 10.Выполняя сортировку выбором.​

Ответ:
Nazar07072004
Nazar07072004
11.01.2021 21:16

#include <iostream>

using namespace std;

int main() {

int a[10],size=10,min,temp;

for (int i = 0; i < 10; i++) {

 cin >> a[i];

}

 

for (int i = 0; i < size - 1; i++) {

 min = i;

 for (int j = i + 1; j < size; j++) {

  if (a[j] < a[min]) {

   min = j;

  }

  temp = a[i];

  a[i] = a[min];

  a[min] = temp;

 }

}

for (int i = 0; i < 10; i++) {

 cout << a[i] << " ";

}

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?