В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
diana20102007
diana20102007
10.09.2020 03:34 •  Информатика

Напишите программу, которая считывает одно натуральное число и выводит на первой строке все делители этого числа порядке возрастания, разделенные пробелами, а на второй "ПРОСТОЕ" или "НЕТ" в зависимости от того, простым было введеное число или нет

Ответ:
zukhra1234
zukhra1234
10.01.2021 14:47

digit=int(input('Введите число:\n'))

delit=1

spisok_del=[]

while delit <= digit:

   if digit % delit == 0:

       spisok_del.append(delit)

   delit+=1

for i in spisok_del:

   print(i,end=' ')

if len(spisok_del)==2 and max(spisok_del)==digit:

   print('\nПростое')

else:

   print('\nНет')

Объяснение: язык программирования - Python

0,0(0 оценок)
Ответ:
sellvladklim00oy13em
sellvladklim00oy13em
10.01.2021 14:47

n = int(input("Введите число: "))

deliteli = [num for num in range(1, int(n**0.5)) if not(n % num)]

deliteli += [n // delitel for delitel in deliteli[::-1]]

print(*deliteli, sep=', ')

print(f"{"простое" if deliteli == [1, n] else "нет"}")

Объяснение:

Нет смысла проверять числа до считываемого числа, остальные можно посчитать

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?