В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
air7789
air7789
24.10.2022 14:53 •  Информатика

Написать программу, которая вводит целые случайные числа в диапазоне от -10 до 10 с оператора random, затем выводит весь массив на экран и после этого выводит на экран количество чисел больших среднего арифметического. Программу нужно написать в паскале

Ответ:
юка28
юка28
09.01.2021 15:24

Среднее арифметическое по условию не выводит.

program v1;

var a:array[0..30]of integer;  

i,n,sum:integer;

t:real;

begin

 sum:=0;

 writeln('Введите размерность матрицы: '); readln(n);

 randomize;

for i:=1 to n do a[i]:=random(20)-10;                            

write('Значение матрицы: ');                                      

for i:=1 to n do write(a[i]:5); writeln;  

for i:=1 to n do begin  

sum:=sum+a[i];

t:= sum/n ;

 end;

 for i:=1 to N do if a[i]>t then write(a[i]:3);

   writeln;

end.


Написать программу, которая вводит целые случайные числа в диапазоне от -10 до 10 с оператора random
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?