В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
partypoison6
partypoison6
07.04.2023 13:30 •  Информатика

напишите программу которая находит в массиве количество элементов равных максимальному ПАСКАЛЬ. ​

Ответ:
azino776
azino776
08.01.2021 04:08

program ghh;

var i, j, k: Integer;

ma: array[1..20] of integer;

begin

j:=0;

k:=0;

for i:=1 to 20 do

begin

ma[i]:= random(10);

if ma[i] > j then

j:= ma[i]

end;

for i:=1 to 20 do

begin

if ma[i] = j then

k:= k + 1;

end;

WriteLn(k)

end.

0,0(0 оценок)
Ответ:

var

a:array[1..100] of integer;

max,i,n:integer;

begin

Randomize;

 for i:=1 to 100 do

  begin

   a[i]:=random(100);

   write(a[i],' ');

  end;

  max:=1;

   for i:=2 to 100 do

    begin

     if a[i]>max then

       max:=a[i];  

    end;

     

        for i:=1 to 100 do

    begin

     if a[i]=max then

       n:=n+1;

    end;

   writeln(' ');

   write(n,' Количество элементов массива равных максимальному')

   

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?