В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Geniud
Geniud
29.04.2022 10:19 •  Информатика

Написать программу. задано натуральное число. определить делится ли оно на два. примечание: проверка делимости на 2 осуществляется следующим образом: пусть n-натуральное число. если n/2=n\2,то число делится на 2, иначе нет. (n/2-обычное деление, n\2-деление нацело)

Ответ:
pactuwka2
pactuwka2
12.06.2020 22:31

вообще признак делимости на 2 можно определить проще. Если остаток от деления на 2=0 тогда число делится на 2 нацело иначе нет if (n mod 2)=0  then writeln('Число  делится на 2 нацело' ) else   writeln('Число не  делиться на 2 нацело' );

Однако если по условию задачи признак, такой то уж ничего не пделаешь 

Program evenNum;

Uses crt;

var n:real;

begin

     clrscr; 

 

     write('Введите число n: ');

     readln(n); 

 

     if ((n/2)<>(n div 2)) then writeln('Число не делится на 2 нацело' )

                 else   writeln('Число  делится на 2 нацело' ); 

    readkey;    

 

end. 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?