В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
DariaGuskova1
DariaGuskova1
12.12.2020 02:03 •  Информатика

Массив состоит из 5 элементов. Элементы массива вводятся с клавиатуры. Это числа 12, 15, 30, 5, 7. Напишите программу, которая вычислит сумму чисел, которые больше 9 и кратны 5.
Программа должна вывести на экран одно число: сумму элементов массива, которые больше 9 и кратны 5.

Ответ:
stovolosova03
stovolosova03
07.01.2021 07:47

#include <iostream>

using namespace std;

long long a[6], i, sum = 0;

int main()

{

   cin >> a[0] >> a[1] >> a[2] >> a[3] >> a[4];

   for(i = 0; i < 5; i++)

       if(a[i] > 9 && !(a[i] % 5))

           sum+=a[i];

   cout << sum << endl;

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?