В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
8Lisandra8
8Lisandra8
09.07.2020 15:50 •  Информатика

Напишите программу для решения задачи : найти сумму отрицательных элементов массива , состоящего из 15 чисел , сформированного случайными числами из диапазона от -20 до 20 (включительно). Полную программу В Паскале (если можно ,то на компе в Паскале с выводом , фото . У меня ноут не поддерживает программу)

Ответ:
Zalina4272Bdjdkxc
Zalina4272Bdjdkxc
08.12.2020 06:10

var

       a: array [1..15] of Integer;

       i, sum: Integer;

       

begin

       Randomize;

       sum := 0;

       

       for i := 1 to 15 do

               a[i] := Random (41) - 21;

       

       for i := 1 to 15 do

               if a[i] < 0 then

                       sum := sum + a[i];

               

       Write (sum)

end.        

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?