В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
zerg314
zerg314
21.08.2022 15:55 •  Информатика

Python 3 нужно написать программу которая будет вычислять факториал 100000 и после него выводить количество нулей в конце данного факториала, а также время за которое исполняется программа
алгоритм должен выполниться быстрее чем приведенный ниже как минимум в 1.5 раза


Python 3 нужно написать программу которая будет вычислять факториал 100000 и после него выводить кол

Ответ:
Сенси
Сенси
05.01.2021 22:43

import time

start_time = time.time()

y = int()

fct = int(1)

z = int(0)

for i in range(1, 100001):

   fct *= i

   y = i

   while ((y % 5) == 0):

       z += 1

       y /= 5

print(fct)

print(z)

print("--- %s seconds ---" % (time.time() - start_time))

input()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?