В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Пелагея9087
Пелагея9087
02.04.2021 07:54 •  Информатика

Написать программу, которая в зависимости от введенного количества минут (m < = 60) будет подставлять слово минута в нужном падеже например, 25 минут 31 минута 53 минуты (используя оператор case и операции div и mod)

Ответ:
Эва637
Эва637
30.09.2020 23:33

var

  M:byte;

begin

  write('M = '); readln(M);

  case M div 10 of

    1: writeln(M, ' минут');

    else

      case M mod 10 of

        0, 5..9: writeln(M, ' минут');

        1: writeln(M, ' минута');

        2..4: writeln(M, ' минуты');

      end;

  end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?