В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
anya2909
anya2909
19.03.2023 14:08 •  Информатика

задача 1: Написать программу для поиска наименьшего элемента в массиве, заданного случайным образом и состоящим из 12 элементов. задача 2: Написать программу для поиска в массиве, заданного случайным образом и состоящим из 20 элементов, элемента, равного 65​

Ответ:
morginen
morginen
05.01.2021 15:51

program test1;

var r, minim, i: integer;

a: array[1..12] of integer;

begin

 for i:=1 to 12 do

 begin

   a[i]:= random(100);

 end;

 minim := a[1];

 for i:=1 to 12 do

 begin

   if minim > a[i] then

     minim:= a[i];

 end;

 writeln('минимальное значение=', minim);

end.

program test2;

var i: integer;

var poisk: string;

a: array[1..20] of integer;

begin

 for i:=1 to 20 do

 begin

   a[i]:= random(100);

 end;

 for i:=1 to 20 do

 begin

   if a[i] = 65 then

     poisk:=poisk + i;

 end;

 if poisk = '' then

   writeln('нет элементов массива со значением 65')

 else writeln('элемент(ы) массива со значением 65 ',poisk)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?