В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
дана34657
дана34657
04.12.2021 23:15 •  Информатика

Сделайте Написать программу нахождения суммы и среднего арифметического значения элементов целочисленного массива размерностью n. С одномерного массива.

n равен количеству букв в вашем имени (например, Лев - размерность 3, или Вероника - размерность 8)

*размерность - количество элементов массива

Ответ:
Rezars19
Rezars19
04.01.2021 02:21

#include <iostream>

using namespace std;

int main() {

srand(time(NULL));

string s;

int n;

float sum=0;

cin>> s;

n= s.length();

int a[n];

for(int i=0;i<n; i++)

{a[i]= random()%10;

sum+=a[i];

cout<<a[i]<<" ";

}

cout<<endl<<"Сумма всех элементов = "<<sum;

float sum1= sum/n;

cout<<endl<<"Среднее арифметическое = "<<sum1;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?