В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Lis666lis
Lis666lis
18.06.2020 22:15 •  Информатика

Перестановка У вас есть массив чисел длиною "N". Нужно найти умноженную вариацию массива. Умноженный вариант массива это такой массив, где nums[i] это произведение всех чисел кроме nums[i]. Например, для массива [1,2,3,4] ответ будет равен [24,12,8,6].

Входные данные:

(1 ≤ n ≤ 10000), где каждый элемент в массиве в промежутке (-10000 ≤ a[i] ≤ 10000)

Выходные данные:

Нужно найти умноженную вариацию массива.

Ответ:
covavector1
covavector1
03.01.2021 19:24

python

arr = [int(i) for i in input('Введите числа через пробел: ').split()]

new_arr = []

for forbidden_index in range(len(arr)):

 first = True

 for index in range(len(arr)):

   if index != forbidden_index:

     if first:

       new_arr.append(arr[index])

       first = False

     else:

       new_arr[forbidden_index] *= arr[index]

print(new_arr)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?