В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Ilona286
Ilona286
30.08.2022 06:31 •  Информатика

Написать программу на языке паскаль : Даны 3 числа a, b, с. Найти минимальное из этих чисел.
Если три числа одинаковые, необходимо что бы на экране выводилось только сообщение: Все числа равны.


Написать программу на языке паскаль : Даны 3 числа a, b, с. Найти минимальное из этих чисел. Если тр

Ответ:
kamila285
kamila285
03.01.2021 13:11

program z1;

var a,b,c,m: integer;

begin

write ('a = ');

readln(a);

write ('b = ');

readln(b);

write ('c = ');

readln(c);

if (a=b) and (b=c) then write('Все числа равны')

else

begin

m:=a;

if b<m then m:=b;

if c<m then m:=c;

write('Минимальное: ',m)

end

end.

Объяснение:

Вводим числа

Если числа равны, то выводим сообщение о равенстве

Иначе:

1) принимаем за минимальное число а

2) сравниваем его с остальными числами, при необходимости заменяем значение минимального

3) выводим минимальное число

0,0(0 оценок)
Ответ:
petrenkof1
petrenkof1
03.01.2021 13:11

begin

 writeln('Введите числа: ');

 var N:Array [1..3] of real;

 readln(N[1],N[2],N[3]);

 write ((N[1]=N[2]) and (N[2]=N[3])1? 'Все числа равны':'Минимальное '+N.Min.ToString);

end.

Объяснение:

(A<>B)? R1:R2 - сокращенная форма оператора if/else, где A,B - сравниваемые значения, R1 - результат, если выражение в скобках верно, R2 - если нет.

N.Min - Находит в массиве наименьший по значению элемент, а .ToString - преобразует его в строку.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?