В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Мелочь83
Мелочь83
06.07.2021 10:20 •  Информатика

напишите программу на ПИТОНЕ! Напишите программу, которая выбирает максимальное и минимальное из пяти введённых чисел.

Входные данные
Входная строка содержит 5 целых чисел, разделённых пробелами.

Выходные данные
В первой строке нужно вывести минимальное из введённых чисел, во второй строке – максимальное.

Примеры
входные данные
1 2 3 4 5
выходные данные
1
5

Ответ:
Анна2849
Анна2849
03.12.2020 12:40

var a,b,c,d,e,max,min:integer;

begin

writeln('a, b, c, d, e:');

readln(a,b,c,d,e);

if a>b then max:=a else max:=b;

if c>max then max:=c;

if d>max then max:=d;

if e>max then max:=e;

if a<b then min:=a else min:=b;

if c<min then min:=c;

if d<min then min:=d;

if e<min then min:=e;

writeln(min);

writeln(max);

end.

Пример:

a, b, c, d, e:

1 2 3 4 5

1

5

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?