В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
SaBzZiRo
SaBzZiRo
04.05.2021 08:30 •  Информатика

составить программу которая заполнит массив размерностью 10 элементов, случайными числами в диапазоне от 1 до 100 и выведет на экран только двузначные числа

Ответ:
Паитаоаипа
Паитаоаипа
01.01.2021 16:45

var a:^array[1..100] of integer;

   n,i,j:integer;

begin

new(a);

repeat

write('Введите размер массива от 1 до 100 n=');

readln(n);

until n in [1..100];

for i:=1 to n do

begin

 a^[i]:=1+random(100);

 write(a^[i]:4);

end

end. язык программирование Pascal

Объяснение:

0,0(0 оценок)
Ответ:
viknik1980p05vqg
viknik1980p05vqg
01.01.2021 16:45

const n=10;

var a:array[1..n] of integer;

    i:byte;

begin

randomize;

writeln('Двузначные числа: ');

for i:=1 to 10 do

begin

 a[i]:= 1 + random(100);

 if (a[i] > 9) and (a[i] < 100) then

 writeln(a[i]);

end;

writeln('Полный массив: ');

for i := 1 to 10 do

writeln(a[i]);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?