В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
LimeAnoW
LimeAnoW
22.03.2023 06:45 •  Информатика

1. написать программу, которая запрашивает массив размерности n и выводит на экран сам массив, а также наибольший и наименьший элементы массива. протестировать программу на массивах размерностью 5 элементов. 2. написать программу, которая запрашивает массив из n элементов, а затем делит все элементы массива на минимальный элемент. протестировать программу на масси- вах размерностью 5 элементов. 3. написать программу, которая запрашивает массив из n элементов и увеличивает все элементы массива на максимальный элемент. протестировать программу на массивах размерностью 8 элементов.

Ответ:
shrnv
shrnv
12.06.2020 16:03
1.                                        

program raf105;

const

 n = 5;

var

 a: array[1..n] of integer;

 x,max,min,i: integer;

begin

writeln('Введите ',n,' по очереди');

for i:=1 to n do

 readln(a[i]);

max:= a[1];

min:= a[1];

for i:=1 to n do

begin

 if max < a[i]

   then max:= a[i];

 if min > a[i]

   then min:= a[i];

end;

writeln;

write('Массив: ');

for i:=1 to n do

 write(a[i],' ');

writeln;

writeln('Наибольший элемент: ',max);

writeln('Наименьший элемент: ',min);

end.

2.                                        

program raf105;

const

 n = 5;

var

 a: array[1..n] of real;

 x,i: integer;

 min: real;

begin

writeln('Введите ',n,' по очереди');

for i:=1 to n do

 readln(a[i]);

writeln;

write('Исходный массив: ');

for i:=1 to n do

 write(a[i],' ');

min:= a[1];

for i:=1 to n do

 if min > a[i]

   then min:= a[i];

for i:=1 to n do

 a[i]:= a[i]/min;

writeln;

write('Изменённый массив: ');

for i:=1 to n do

 write(a[i],' ');

end.

3.                                        

program raf105;

const

 n = 8;

var

 a: array[1..n] of integer;

 x,i,max: integer;

begin

writeln('Введите ',n,' по очереди');

for i:=1 to n do

 readln(a[i]);

writeln;

write('Исходный массив: ');

for i:=1 to n do

 write(a[i],' ');

max:= a[1];

for i:=1 to n do

 if max < a[i]

   then max:= a[i];

for i:=1 to n do

 a[i]:= a[i]+max;

writeln;

write('Изменённый массив: ');

for i:=1 to n do

 write(a[i],' ');

end.

                                          PascalABC 3.4.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?