В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nastya4431
nastya4431
08.09.2020 07:43 •  Информатика

Написать программу с функцией,которая возвращает в основную программу кол-во гласных букв

Ответ:
катя19052
катя19052
30.09.2020 22:44

program raf105;

var  

 s: string;

 g: integer;

 

function glas(s:string): integer;

const

 glas_list = 'аяоёуюыиэе';

var  

 i,j,res:integer;

begin

 s:= lowercase(s);

 for i:=1 to length(s) do

   for j:=1 to length(glas_list) do

     if s[i] = glas_list[j]

       then res:= res + 1;

glas:= res;

end;

begin

write('Введите строку: ');

readln(s);

g:= glas(s);

writeln('В строке ',g,' глас.');

end.

PascalABC 3.4.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?