В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dianasadykovaaaa
dianasadykovaaaa
24.03.2022 10:25 •  Информатика

1)написать программу,которая спрашивает"который час? " и,в зависимости от введенного времени,выводит : "доброе утро","добрый день","добрый вечер", "спокойной ночи". 2)написать программу,которая определяет,принадлежит ли точка с координатами (x,y)заштрихованной области,ограниченной точками(x1,y1)(x2,y2).

Ответ:
ева19961
ева19961
12.06.2020 12:51

PROGRAM Privet;

VAR

x:real;


BEGIN

writeln('Который час?'); read(x);

if x > 24 then

  writeln('Введенное число не является временем ' )

else

begin

if (x>=8) and (x<12)  then writeln('Доброе утро!');

if (x>=12) and (x<17)    then writeln('Добрый день!');

if(x>=17) and (x<23)    then writeln('Добрый вечер!');

if(x>=23) or (x<8)  then writeln('Доброй ночи!');

end;

end.

 

 

//вторая программа

var

  x,x1,x2,y,y1,y2:real;

begin

  write('x = '); readln(x);

  write('y = '); readln(y);

  write('x1 = '); readln(x1);

  write('y1 = '); readln(y1);

  write('x2 = '); readln(x2);

  write('y2 = '); readln(y2);

  if ((x - x1) * (x - x2) < 0) and ((y - y1) * (y - y2) < 0) then

    writeln('Точка принадлежит заданной области')

  else

    writeln('Точка не принадлежит заданной области');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?