В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Mdsk01
Mdsk01
16.01.2022 07:48 •  Информатика

На языке паскаль написать программу производящую перевод из десятичной системы счисления в шестнадцатиричную и обратно. с выбором операции.

Ответ:
andriymoskalet
andriymoskalet
12.06.2020 12:20

var

a : integer;
flag : byte;
s : string;

function HexToDec (s : string) : integer;
var
i, d, dig : integer;
res : integer;
begin
d := 1;
res := 0;
for i := length (s) downto 1 do
begin
dig := ord (s[i]);
if dig < 58 then res := res + (dig - 48) * d
else res := res + (dig - 55) * d;
d := d * 16;
end;
HexToDec := res;
end;

function DecToHex (a : integer) : string;
var
dig : integer;
c : char;
res : string;
begin
res := '';
repeat
dig := a mod 16;
if dig < 10 then c := chr (dig + 48)
else c := chr (dig + 55);
res := res + c;
a := a div 16;
until a = 0;
DecToHex := res;
end;

function Revert (s : string) : string;
var
i : integer;
r : string;
begin
r := '';
for i := length (s) downto 1 do
r := r + s[i];
Revert := r;
end;

begin
writeln ('Введите систему счисления, в которую переводим');
readln (flag);
if (flag = 16) then
begin
writeln ('Введите число в десятичной системе счисления');
readln (a);
writeln (Revert (DecToHex (a)));
end
else if (flag = 10) then
begin
writeln ('Введите число в шестнадцатиричной системе счисления');
readln (s);
writeln (HexToDec (s));
end
else writeln ('Ошибка : неверная система счисления');
readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?