В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
marek2
marek2
12.12.2022 09:41 •  Информатика

Надо написать программу на Pascal. Вася готовится к муниципальному этапу олимпиады по информатике, он хочет показать на нём хороший результат. Чтобы добиться этого, он разработал собственную систему тренировок — он каждый день решает задачи. Причём, он решает разное количество задач в будние и в выходные дни.

В будний день Вася решает
X
задач, в выходной день —
Y
задач.

Выходным Вася считает каждый
K
-й день, то есть дни с номерами
K
,
2
K
,
3
K
,

являются выходными.

Вася будет готовиться к олимпиаде ровно
N
дней и он хочет заранее знать, сколько всего задач он решит. Считается, что Вася решает задачи, начиная с дня с номером 1.

Требуется написать программу, которая по данным
N
,
K
,
X
,
Y
вычисляет количество решённых задач.

Входные данные
В первой строке вводится натуральное число
N
(
1

N

1000
) - количество дней, которое Вася будет решать задачи для подготовки к олимпиаде.

Во второй строке вводится натуральное число
K
(
1

K

1000
) - номер первого выходного дня.

В третьей строке вводится натуральное число
X
(
1

X

1000
) - количество задач, которое Вася решает в будний день.

В четвёртой строке вводится натуральное число
Y
(
1

Y

1000
) - количество задач, которое Вася решает в выходной день.

Пример
входные данные
3
2
10
15

выходные данные
35

Ответ:
biv12448
biv12448
27.12.2020 10:38

program abc;

var n,k,x,y:integer;

begin

   readln(n);

   readln(k);

   readln(x);

   readln(y);

 writeln((k)*x+(n-k)*y);  

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?